Составить программу в кумире: Измените код программы сумма цифр двузначного числа так, чтобы программа меняла цифры двузначного числа местами. Например, ввод: 81, вывод: 18.
Задача №1 var a:array[1..4, 1..5] of integer; i,j,k:integer; begin writeln('Заполните матрицу'); for i:=1 to 4 do for j:=1 to 5 do begin read(a[i,j]); if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; end; writeln('Сумма элементов кратных 3-м и > 20 = ',k); end.
Задача №2 var a:array[1..5, 1..5] of integer; i,j,k:integer; begin writeln('Заполните матрицу'); for i:=1 to 5 do for j:=1 to 5 do begin read(a[i,j]); if i=j then k:=k+a[i,j]; end; writeln('Сумма элементов главной диагонали = ',k); end.
var a:array[1..4, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 4 do
for j:=1 to 5 do begin
read(a[i,j]);
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j];
end;
writeln('Сумма элементов кратных 3-м и > 20 = ',k);
end.
Задача №2
var a:array[1..5, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 5 do
for j:=1 to 5 do begin
read(a[i,j]);
if i=j then k:=k+a[i,j];
end;
writeln('Сумма элементов главной диагонали = ',k);
end.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32
2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт
3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16
4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит
8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт