В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
valeriy345
valeriy345
02.06.2020 08:20 •  Информатика

Составить программу в которой необходимо получить случайное число, на отрезке от 1 до 99 (pascal)​

Показать ответ
Ответ:
Georgii1998
Georgii1998
03.05.2023 08:59
Var
  M, tons, kilos, grams: integer;
begin
  write('Введите массу: ');
  read(M);
  // чтобы найти кол-во тонн, разделим нацело введенную массу
  // на 1000000
  tons := M div 1000000;  // div - деление нацело
  // чтобы найти кол-во килограмм, сначала возьмем остаток 
  // деления на 100000, затем полученное число разделим
  // нацело на 1000.
  kilos := (M mod 100000) div 1000;  // mod - остаток от деления
  // граммы - последние 3 цифры введенного числа
  grams := M mod 1000;
  writeln(tons, ' т. ', kilos, ' кг ', grams, ' г.');
end.
0,0(0 оценок)
Ответ:
Kachelda
Kachelda
03.05.2023 08:59
А вот и ошибочка!  Вот алгоритм в исправленном виде!

var  M, tons, kilos, grams: integer;begin  write('Введите массу: ');  read(M);  // чтобы найти кол-во тонн, разделим нацело введенную массу  // на 1000000  tons := M div 1000000;  // div - деление нацело  // чтобы найти кол-во килограмм, сначала возьмем остаток   // деления на 100000, затем полученное число разделим   // нацело на 1000.  kilos := (M mod 100000) div 1000;  // mod - остаток от деления  // граммы - последние 3 цифры введенного числа  grams := M mod 1000;  writeln(tons, ' т. ', kilos, ' кг ', grams, ' г.');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота