В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
valyashchenko20
valyashchenko20
13.03.2020 15:20 •  Информатика

составить программу в delphi для нахождения функций y (x), где х Є [a, b] с использованием различных операторов цикла (while, do while и for). Организовать ввод значений a, b выбор шага hx y=x3 + 2 sin x

Показать ответ
Ответ:
svetlanaGB
svetlanaGB
22.01.2023 12:07

Алгоритм:

1) Считываем входные данные. Перехваченную шифровку записываем в переменную encoded, количество гипотез Антона в переменную N, а сами гипотезы в переменную assumptions.

2) Сортируем буквы в перехваченной шифровке, сохраняем получившийся список в переменную encoded_sorted.

3) Проходимся циклом по всем гипотезам, во время каждой итерации сортируем буквы в гипотезе и сверяем с encoded_sorted. В случае если равно, гипотеза верна => выводим.

Код на Python:

encoded = input()

N = int(input())

assumptions = [input() for _ in range(N)]

encoded_sorted = sorted(encoded)

for assumption in assumptions:

   if sorted(assumption) == encoded_sorted:

       print(assumption)

       

0,0(0 оценок)
Ответ:
MrCapuchino
MrCapuchino
01.07.2020 06:38

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

// Variables

double a = 0, b = 0, c = 0;

double x;

double condition;

double sub_condition;

double y;

// Input

cout << "Input numbers:" << endl;

cout << "a = ";

cin >> a;

cout << "b = ";

cin >> b;

cout << "c = ";

cin >> c;

cout << "x = ";

cin >> x;

// Create condition

condition = abs(1 - pow(x, 2));

sub_condition = a + c;

//  Solution

if (condition == sub_condition) {

 y = sqrt(abs(a * x - pow(cos(pow(b, 3)), 2) * x + 5.1 * pow(c, 2)));

}

else if (condition > sub_condition) {

 y = exp(0.04 * x) + log(pow(b, 5) * cos(x));

}

else {

 y = pow(cos(pow(b, 3) * pow(x, 2)), 2) + log(abs(b * x - pow(a, 2)));

}

cout << "Answer: y = " << y << endl;

return 0;

}


Создать ОДНУ программу расчета функции y(x) для трех разных параметров на С++. Переменная x вводится
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота