Составить программу узоров под номерами 4,5,6 и 7 в приложении кумир.использовать стандартные циклы (вверх, вниз, вправо, влево) и дополнительный (нц пока кц)
Program pr1; Var A : array [1..4, 1..4] of integer ; {резервирование памяти под массив А (4 на 4)} i,j, max, p, k: integer ; {переменные i,j вводятся как индексы массива} Begin randomize; For i:=1 to 4 do For j:=1 to 4 do A[i,j]:=random (100); {ввод элемента матрицы} max:=A[1,1]; k:=1; p:=1; {первоначальное предположение} For i:=1 to 4 do For j:=1 to 4 do if A[i,j]>max then begin {Если текущий элемент больше максимального } max:=A[i,j]; {max = A[i,j], запоминаем индексы текущего элемента} k:=i; p:=j; end;
writeln('Исходный массив:'); For i:=1 to 4 do begin For j:=1 to 4 do write (A[i,j], ' '); writeln; end;
Ну, площадь круга, допустим, вычисляется по формуле
S = pi*R^2.
Ну а кольца из большего круга вычитаем меньший, получим
Sk = pi*(R1^2 - R2^2)
Вот собственно и всё.
Программы тут и нет, так, пара операторов, например
Пи=3,141592653;
Ввод(R1,R2);
S = Пи*ABS(R1*R1-R2*R2);
Сообщить(R1,R2,S);
Замечание1. Модуль (ABS) обязателен, для снятия ограничений на порядок ввода радиусов. При таком подходе порядок(больший-меньший или наоборот) роли НЕ ИГРАЕТ!
Замечание2 Написано некоем псевдоязыке, с которого легко переведёшь на тот, которым владеешь.
Program pr1;
Var A : array [1..4, 1..4] of integer ; {резервирование памяти под массив А (4 на 4)}
i,j, max, p, k: integer ; {переменные i,j вводятся как индексы массива}
Begin
randomize;
For i:=1 to 4 do
For j:=1 to 4 do
A[i,j]:=random (100); {ввод элемента матрицы}
max:=A[1,1]; k:=1; p:=1; {первоначальное предположение}
For i:=1 to 4 do
For j:=1 to 4 do
if A[i,j]>max then begin {Если текущий элемент больше максимального }
max:=A[i,j]; {max = A[i,j], запоминаем индексы текущего элемента}
k:=i;
p:=j;
end;
writeln('Исходный массив:');
For i:=1 to 4 do begin
For j:=1 to 4 do
write (A[i,j], ' ');
writeln;
end;
a[k, p] := a[k, p] + a[1, 1]; // добавленные строки
a[1, 1] := a[k, p] - a[1, 1];
a[k, p] := a[k, p] - a[1, 1];
writeln('Преобразованный массив:');
For i:=1 to 4 do begin
For j:=1 to 4 do
write (A[i,j], ' ');
writeln;
end;
writeln ('Максимальный элемент матрицы = ', max);
write ('Он находится в строке №' , k);
writeln (' и в столбце №' , p);
end.
Ну, площадь круга, допустим, вычисляется по формуле
S = pi*R^2.
Ну а кольца из большего круга вычитаем меньший, получим
Sk = pi*(R1^2 - R2^2)
Вот собственно и всё.
Программы тут и нет, так, пара операторов, например
Пи=3,141592653;
Ввод(R1,R2);
S = Пи*ABS(R1*R1-R2*R2);
Сообщить(R1,R2,S);
Замечание1. Модуль (ABS) обязателен, для снятия ограничений на порядок ввода радиусов. При таком подходе порядок(больший-меньший или наоборот) роли НЕ ИГРАЕТ!
Замечание2 Написано некоем псевдоязыке, с которого легко переведёшь на тот, которым владеешь.