В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kotovak27
kotovak27
03.08.2021 14:19 •  Информатика

Составить программу умножающую две обыкновенные дроби. как в pascal

Показать ответ
Ответ:
Даник2254
Даник2254
06.10.2020 21:57
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

uses NumLibABC;

begin
   var (num,denom):=ReadInteger2('Числитель и знаменатель 1-й дроби:');
   var f1:=Frc(num,denom);
   (num,denom):=ReadInteger2('Числитель и знаменатель 2-й дроби:');
   var f2:=Frc(num,denom);
   f1.Print; Write('* '); f2.Print; Write('= '); (f1*f2).Print
end.

Примеры
Числитель и знаменатель 1-й дроби: 4 9
Числитель и знаменатель 2-й дроби: 3 8
4/9 * 3/8 = 1/6

Числитель и знаменатель 1-й дроби: 32432424 10213133
Числитель и знаменатель 2-й дроби: 23123 12313123
32432424/10213133 * 23123/12313123 = 749934940152/125755562844359

Числитель и знаменатель 1-й дроби: 15 2
Числитель и знаменатель 2-й дроби: 8 15
15/2 * 8/15 = 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота