Составить программу строго по с++! без if
условие
1)
дан порядковый номер дня года (отсчет идет с 1-го января). выведите номер дня недели этого дня, если 1 января — вторник.
формат входных данных
вводится номер дня года — целое число
k
(1≤≤365)
.
формат выходных данных
требуется вывести номер дня недели для данного дня года (понедельник — 1, вторник — 2, воскресенье — 7).
2)мэрия города м-ска приняла решение провести реновацию домов на улице льва толстого. как известно, дома на этой улице нумеруются натуральными числами от 1 до n, при этом на одной части улицы стоят дома с чётными номерами, а на другой — с нечётными. кроме этого, дома с номерами от l до r относятся к застройке, и под программу реновации не .
мэрии определить, сколько домов попадет под программу реновации на чётной стороне улицы.
формат входных данных
на вход программе три целых числа n, l и r (1 ≤ l ≤ r ≤ n ≤ 1018).
формат выходных данных
требуется вывести одно целое число — количество домов, которые попадут под программу реновации на чётной стороне улицы.
примечания
в первом примере из условия на чётной стороне улицы 5 домов — 2, 4, 6, 8 и 10. из них дома 4 и 6 относятся к застройке, поэтому под программу реновации не попадут. оставшиеся три дома имеют номера 2, 8, 10.
во втором примере, вся чётная сторона улицы относится к застройке.
Вот первая задача
Объяснение:
#include <stdio.h>
int main()
{
int k;
printf("Введите номер дня\n");
scanf("%i", &k);
if((k < 1)||(k > 365))
{
printf("День не подходит");
return 0; // немедленный выход из функции и приложения
}
int den = k % 7; //операция остаток от деления. Тут будет номер дня недели от 0 до 6
den = den + 1 + 2; // 2 - это номер первого дня года, вторника, 1 - это чтобы преобразовать из диапазона 0-6 в диапазон 1-7
printf("День номер %i был %i днем недели", k, den);
return 0;
}