Составить программу, спрашивающую у ученика его отметку по информатике и реагирующую на нее подходящим текстом 1-4 - кошмар! 5-6 - неважно. 7-8 - неплохо . 9-10 - молодец!
Program n1; var m: integer; begin readln(m); case m of 1..4: writeln('кошмар!'); 5..6: writeln('неважно.'); 7..8: writeln('неплохо.'); 9..10: writeln('молодец!'); end; end.
Program z213124; var a:integer; begin write ('введите ваш ' ); readln (a); if (a>=1) and (a<=4) then write ('кошмар!'); if (a>=5) and (a<=6) then write ('неважно'); if (a>=7) and (a<=8) then write ('неплохо'); if (a>=9) and (a<=10) then write ('молодец!'); end.
var m: integer;
begin
readln(m);
case m of
1..4: writeln('кошмар!');
5..6: writeln('неважно.');
7..8: writeln('неплохо.');
9..10: writeln('молодец!');
end;
end.
var a:integer;
begin
write ('введите ваш ' );
readln (a);
if (a>=1) and (a<=4) then write ('кошмар!');
if (a>=5) and (a<=6) then write ('неважно');
if (a>=7) and (a<=8) then write ('неплохо');
if (a>=9) and (a<=10) then write ('молодец!');
end.