составить программу:
Составить программу нахождения среднего арифметического значения всех делителей заданного натурального числа N, кратных 3.
Вывести 0, если нет делителей.
(Само число и единица включаются в число делителей.)
Формат входных данных
Входной файл содержит число N (1≤N≤1000).
Формат выходных данных
Выведите искомую величину с точностью не менее 10^−9.
Примеры:
Вход
6
Выход
4.5000000000
1) a x a = a² ⇒ b; b x a = a³ ⇒ результат
2) a x a = a² ⇒ b; b x b = a⁴ ⇒ c; c x c = a⁸ ⇒ c; c x b = a¹⁰ ⇒ результат
Программа на языке PascalABC.Net
var
a,b,c,y:real;
begin
Write('Введите число: '); Read(a);
b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
c:=b*b; c:=c*c; y:=b*c;
Writeln('Десятая степень числа равна ',y)
end.
Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024
Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
задача1 чтобы подсчитать общее количество равновероятных событий (количество подъездов) воспользуемся формулой N=2^i вместо i подставим 2 и получим N=2^2, т.е. 4
ответ: в доме 4 подъезда
задача2 чтобы подсчитать общее количество равновероятных событий (количество ящиков) воспользуемся формулой N=2^i вместо i подставим 3 и получим N=2^3, т.е. 8
ответ: на склад поступило 8 ящиков
задача4 в тексте 61 символ. при использовании 256 -символьного алфавита, вес 1 символа составляет 8 бит
умножим 8 на 61 получим 488 бит
задача5
запишем условие: страниц=3, строк=60, символы=65, I=8775 байт, N=?
решение: выразим информационный объем текста в битах
I=8775*8=70200 бит
узнаем сколько всего символов в тексте
К=3*60*65=11700
теперь вычислим вес одного символа
i=I/K=70200/11700=6 бит
применим теперь формулу мощности алфавита:
N=2^i, N=2^6, N=64