В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anastasia1292
anastasia1292
22.08.2022 07:47 •  Информатика

Составить программу сокращения одномерного числового массива путем удаления а) всех элементов с нулевыми значениями дополнительный массив использовать не ! , а то !

Показать ответ
Ответ:
Сапсан936
Сапсан936
07.06.2020 04:59

var

  a : array [1..100] of integer;

  i, next, n : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  next := 1;

  for i := 1 to n do

    if a[i] <> 0 then

    begin

      a[next] := a[i];

      next := next + 1;

    end;

  n := next - 1;

  for i := 1 to n do

    write (a[i], ' ');

end.

 

В результате работы в N будет лежать новая длина, а после массива - будет лежать всяий мусор (огрызок прежднего массива), но это неважно.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота