В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
shapovalova12345
shapovalova12345
24.01.2021 11:46 •  Информатика

Составить программу. -сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен квадрату текущего индекса, увеличенному на 5; 2-й равен целой части квадратного корня из предыдущего элемента; 3-й равен целой части от деления двух предыдущих элементов.

Показать ответ
Ответ:
fdimon
fdimon
22.06.2020 00:55
Var
  i : integer;
  aa : array[1..9] of integer;

begin
  { высчитываем элементы массива }
  for i := 1 to 9 do
    if i mod 3 = 1 then
      aa[i] := (i + 5) * (i + 5)
    else if i mod 3 = 2 then
      aa[i] := round(sqrt(aa[i-1]))
    else
      aa[i] := aa[i-1] div aa[i-2];
  { выводим значения на экран }
  for i := 1 to 9 do
    write(aa[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота