В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vasilyukandrey
vasilyukandrey
05.10.2020 17:01 •  Информатика

составить программу с процедурой выводящую на экран 4 горизонтальные линии из символов ''*'':1 линия -7 символов,2 линия-19 символов,3 и 4 линия любое количество символов(<80,количество символов вводить с клавиатуры).Написать в паскале

Показать ответ
Ответ:
tati9860406
tati9860406
11.07.2021 15:58

Код программы:

procedure print(a, b:integer);

var i:integer;

begin

 for i:=1 to 7 do

   write('*');

 writeln();

  for i:=1 to 19 do

   write('*');

  writeln();

  for i:=1 to a do

   write('*');

   writeln();

  for i:=1 to b do

   write('*');

end;  

var a,b:integer;

begin

 writeln('Введите количество символов на 3 уровне(<80): ');

 readln(a);

 writeln('Введите количество символов на 4 уровне(<80): ');

 readln(b);

 if (a < 80) and (b < 80) then

     print(a,b)

 else

   writeln('Ошибка! Количество символов >= 80');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота