Составить программу решения задачи с использованием условного оператора (первое задание). 1. Ввести три действительных числа х, у и z. Вычислить значения q и w по формулам
q=mах(ху,х+уz,у+хz); w = min(х+2у+z, 2х+у+ z)+1. Напечатать их
Составить программу решения задачи с использованием оператора выбора (второе задание).
2. Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.
V – логическая операция ИЛИ. В результате будут найдены страницы, в которых есть хотя бы одно из двух слов, между которыми находится эта операция.
& – логическая операция И. В результате будут найдены страницы, в которых есть оба слова, между которыми находится эта операция.
Отняв от количества страниц, в которых есть хотя бы одно из слов "Мороз" или "Солнце" количество страниц, в которых есть оба этих слова, получим сумму страниц, в которых есть только слово "Мороз" или только слово "Солнце"
2870 - 1100 = 1770
Известно, что запросов, в котором есть только слово Мороз 1654. Отнимем это число от суммы страниц, в которых есть только слово "Мороз" или только слово "Солнце".
1770 - 1654 = 116
ответ: 116 страниц.
function Avg(a:array[,] of integer):real;
begin
var s:=0; var k:=0;
foreach var e:integer in a do
if e>0 then begin s+=e; Inc(k) end;
if k>0 then Result:=s/k else Result:=1e-100;
end;
begin
var A:=MatrixRandom(4,4,-50,50); Writeln(A);
Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
var B:=MatrixRandom(5,5,-30,30); Writeln(B);
Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
var C:=MatrixRandom(4,5,-25,38); Writeln(C);
Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.
Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200