В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
arinuhkas
arinuhkas
28.04.2021 06:37 •  Информатика

Составить программу решения уравнения (x-a²)×(x+b²)=c² относительно х в pascal abc

Показать ответ
Ответ:
kateshaginian
kateshaginian
03.03.2022 16:08
1) на что мы используем Интернет (контакты, поиск информации для обучения, поиск инфы для жизни и т. д. ) 2) чем заменить все эти вещи без Инета (телефон и письма, учебники, и т. д.) 3) в чём разные хуже или лучше (напр, по телефону можно так же быстро поговорить, как и через Инет, но нельзя быстро переслать печатный текст. Бумажное письмо очень приятно писать и получать, но оно идёт слишком медленно, контакт по интернету самый быстрый, но немного теряется тепло живого общения) и так по всем пунктам. 4) большие области на нашей планете, где нет Инета или он плохой (медленный) и редко встречается (Африка). 5) в некоторых восточных странах Инет регулируется на государственном уровне (Китай, Корея) 5) вывод - в принципе, без Инета прожить можно, но во многих областях без него гораздо хуже и медленнее.
0,0(0 оценок)
Ответ:
Натали2004абвг
Натали2004абвг
24.04.2023 17:01
Сумма всех четных чисел от 1 до 200 - это на самом деле сумма чисел
2+4+6+...+198+200.

1. Самый короткий вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  Writeln(Range(2,200,2).Sum)
end.

Результат:
10100

2. Более длинный и более "школьный" вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var s:=0;
  var i:=2;
  while i<=200 do begin
    s:=s+i;
    i:=i+2
    end;
  Writeln(s)
end.

3. Совсем "тупой школьный" вариант (решение "в лоб")

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
  i,s:integer;
begin
  s:=0;
  for i:=1 to 200 do
    if i mod 2 =0 then s:=s+i;
  Writeln(s)
end.

4. Улучшенный "школьный" вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
  i,s:integer;
begin
  s:=0;
  for i:=1 to 100 do s:=s+2*i;
  Writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота