В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
GiraAronEchwik
GiraAronEchwik
14.05.2021 09:40 •  Информатика

составить программу решения реальной задачи из учебника математики алгоритм линейный + не забывайте общую структуру программы

Показать ответ
Ответ:
ryazhechkina
ryazhechkina
02.10.2020 01:53

from itertools import product

i = open('input.txt', 'r')

o = open('output.txt', 'w+')

l = int(i.

alpha = "245"

d = []

for s in product(alpha, repeat=l):

    d.append([" ".join(

for q in d[1: ]:

    s = " ".join(q)

    if int(s.count('2')) > 2:

        continue

    o.write(" ".join(q) + '\n')

i.close()

o.close()

код к : «перевод кода с питона на паскаль»

var

n,c,i,ost,b,t,d: integer;

a,k: string;

begin

readln(n);

c: =1;

for i: =1 to n do

c: =c*3;

c: =c-1;

for i: =1 to c do

begin

k: ='';

b: =i;

t: =0;

while b> 0 do

begin

ost: =b mod 3;

if ost=0 then inc(t);

d: =(-sqr(ost)+5*ost+4)div 2;

str(d,a);

k: =a+k;

b: =b div 3;

end;

while length(k)do

begin

k: ='2'+k;

inc(t);

end;

if t< =2 then writeln(k);

end;

end.

0,0(0 оценок)
Ответ:
petrovaanastasia26
petrovaanastasia26
18.04.2021 04:42
Великий писатель, драматург, публицист, граф лев николаевич толстой родился 9 сентября (28 августа по старому стилю) 1828 года в имении ясная поляна крапивенского уезда тульской губернии (ныне щекинского района тульской области) в одном из самых знатных дворянских семейств. он был четвертым ребенком в семье. детство будущего писателя прошло в ясной поляне. он рано осиротел, потеряв сначала мать, которая умерла, когда мальчику было два года, а затем и отца. в 1837 году семья переехала из ясной поляны в москву. опекуншей осиротевших детей стала их тетка, сестра отца александра ильинична остен-сакен. в 1841 году, после ее смерти, юный толстой с сестрой и тремя братьями переехал в казань, где жила другая тетка - пелагея ильинична юшкова, ставшая их опекуншей. подробнее - на -
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота