В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mumu9
mumu9
03.05.2022 06:12 •  Информатика

Составить программу, решающую следующую : дано число а. не пользуясь никакими другими операциями, кроме умножения, получить: за 3 операции.

Показать ответ
Ответ:
Lop1234kop
Lop1234kop
15.07.2020 21:52
\displaystyle x=a^8={((a^2)^2})^2={((a\times a)^2)}^2 \\ a_1:=(a\times a); \ a_2:=(a_1\times a_1); \ a_3:=(a_2\times a_2)


var
  x,a,b:longint;
 
begin
  a:=3;
  a:=a*a;
  a:=a*a;
  x:=a*a;
  Writeln('3 в степени 8 равно ',x)
end.

Тестовое решение:
3 в степени 8 равно 6561
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота