В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sunnyAkhhhh
sunnyAkhhhh
02.07.2020 18:05 •  Информатика

Составить программу проверки знания таблицы умножения. сценарий: компьютер спрашивает: «проверим? » (варианты ответов: 0 – «нет», 1 – «да») . если играющий отвечает «да», то компьютер с генератора случайных чисел задает 2 числа и запрашивает их произведение. после проверки правильности ответа компьютер сообщает «правильно» или «неправильно» и подсчитывает количество правильных ответов и ошибок. затем компьютер вновь спрашивает: «проверим? ». по окончании работы цикла компьютер выдает статистику игры: сколько всего задано вопросов, количество правильных ответов и число ошибок.

Показать ответ
Ответ:
Еролггштши
Еролггштши
08.10.2020 23:45
\n";

   cout << "Correct answer > " << a * b << endl;

   FalseCounter++;

   Sleep(2500);

  }

  break;

 case 2:

  end = 1;

  break;

 }

} while (end != 1);

system("cls");

cout << "Game Info : \n";

cout << "Question counter > " << Counter << endl;

cout << "Correct answer > " << TrueCounter << endl;

cout << "Incorrect anser > " << FalseCounter << endl;

system("pause");

return 0;

}


Составить программу проверки знания таблицы умножения. сценарий: компьютер спрашивает: «проверим? »
0,0(0 оценок)
Ответ:
yanastepina83
yanastepina83
08.10.2020 23:45

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

var c, w: integer;

procedure check;

begin

 var (a, b) := (Random(0, 20), Random(0, 20));

 Print($'{a}*{b}=');

 if a * b = ReadInteger then begin inc(c); Println('Правильно') end

 else begin inc(w); Println('Неправильно') end;

end;

procedure res;

begin

 Println($'Задано вопросов {c+w}');

 Println($'Правильных {c}({(c*100)/(c+w):f1}%)');

 Println($'Неправильных {w}({(w*100)/(c+w):f1}%)');

end;


begin

 var start := true;

 while start do

 begin

   Println('Проверим?(0/1)');  

   if ReadInteger = 0 then

   begin start := false; res; end

   else check;

 end;

end.


Пример в приложении.


Составить программу проверки знания таблицы умножения. сценарий: компьютер спрашивает: «проверим? »
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота