В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
RihDest
RihDest
02.06.2021 18:57 •  Информатика

Составить программу получающую на входе целое число a. Если a меньше 0, тогда a:=a+3, иначе a:=a-1. Какой результат выдаст программа при a = 0, a = -5, a=5?
Составить программу в паскаль, если можно то скрином из паскаля!

Показать ответ
Ответ:
kasym2
kasym2
12.10.2020 09:16

var

 a: integer;

begin

 Read(a);

 if a < 0 then a := a + 3 else a := a - 1;

 Writeln('Конечный результат', a);

end.

Тестовое решениеЖ

Введите А := 0

Конечный результат-1

Введите А  -5

Конечный результат-2

Введите А  -5

Конечный результат 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота