В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

составить программу по информатике!
Задание: Набрать приведенную ниже программу в среде pascalABC.NET.
В прилагается схема.

Программа на языке Pascal:

//Вывести числа от 1 до 10 через пробел
program while1;
var i:integer //целое число
begin
writeln('Вас приветствует программа Петрова П')
i := 1; //задать начальное значение переменной i
while (i <= 10) do
begin
write (i, ' '); //Вывод значений переменной i через пробелы
i := i + 1; //Увеличение значения переменой i на 1
end;
end.

Показать ответ
Ответ:
vladacherry2003
vladacherry2003
25.06.2022 03:34

Цифровой гироскопический датчик предназначен для измерения угла и

направления вращения робота, а также скорости его вращения. Точность

измерения составляет +/-30 , максимальная скорость проведения измерений

4400/сек., частота опроса датчика 1кГц.

Будучи включенным, при длительном нахождении робота в неподвижном

состоянии, определяемое значение угла не остаётся постоянным, а ошибочно

меняется или дрейфует. Поэтому, чем больше времени проходит от начала

первого обращения к гироскопическому датчику до чтения показаний, тем

менее точным становятся результаты за счёт систематического накопления

ошибки. Поэтому перед началом каждого измерения всегда необходимо

производить обнуление угла при режима Сброс.

Сорян, это всё что я знаю о лего

0,0(0 оценок)
Ответ:
Dilnaz10011
Dilnaz10011
12.08.2022 04:07

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота