В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Anny2107
Anny2107
01.04.2022 00:52 •  Информатика

Составить программу по информатике в pascal abc. 1. с клавиатуры одной строковой вводят имя и фамилию. составьте программу, которая: а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и
выводит его; в) выводит сначала фамилию, а затем имя. 2. составьте программу, которая в строке "касіу ясь канюшыну" заменяет имя "ясь" на "янка". 3. составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы";
б) заменяет слово "болота" на "озера". буду безмерно !

Показать ответ
Ответ:
Qw135tgv245
Qw135tgv245
06.06.2020 21:20

Задание 1

a)

program pr;

var

s:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

writeln('Введите заданный символ');

readln (c);

for i:=1 to length(s) do if s[i]=c then writeln ('В строке найден заданный символ');

readln;

end.

б)

program pr;

var

s,n:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

writeln(n);

readln;

end.

в)

program pr;

var

s,n,f:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

f:=copy(s,i+1,length(s)-i+1);

writeln(n);

writeln(f);

readln;

end.

Задание2

program pr;

var s:string;

begin

s:='Касіу Ясь канюшыну';

delete (s,7,3);

insert ('Ясь',s,7);

writeln (s);

readln;

end.

Задание 3

а)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete (s,6,5);{удаляем включая пробел}

writeln (s);

readln;

end.

б)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete(s,13,6);

s:=s+'озера';

writeln (s);

readln;

end.

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота