Составить программу перевода строки, представляющей собой запись целого положительного числа, в соответствующую величину целого типа (не используя процедуру val) си
A)var k,n:integer; begin read(k); if k div 7=k/7 then n:=7 else if k+1 div 7=k+1/7 then n:=6 else if k+2 div 7=k+2/7 then n:=5 else if k+3 div 7=k+3/7 then n:=4 else if k+4 div 7=k+4/7 then n:=3 else if k+5 div 7=k+5/7 then n:=2 else if k+6 div 7=k+6/7 then n:=1; writeln(n); end. б)var k,n:integer;begin read(k); if k-1 div 7=k-1/7 then n:=7 else if k div 7=k/7 then n:=6 else if k+1 div 7=k+1/7 then n:=5 else if k+2 div 7=k+2/7 then n:=4 else if k+3 div 7=k+3/7 then n:=3 else if k+4 div 7=k+4/7 then n:=2 else if k+5 div 7=k+5/7 then n:=1; writeln(n); end.
1.) программаға сәйкес операцияларды орындауға арналған компьютердің негізгі құрылғысы, қызметтік бөлігі. Көптеген жартылай өткізгішті элементтерден тұратын және компьютерде барлық есептеулер мен ақпарат өндеу жұмыстарын орындайтын электрондық микросхема. Қазіргі компьютерлерде бір немесе бірнеше процессорлар жұмыс істейді.
2.Процессор деген компьютердегі барлық қызметті атқарып тұрған адамның миы сияқты құрылғы, арифметикалық-логикалық қызметтер атқарады. процессорды CPU американдық компаниялар Intel, AMD жасап шығарады.
ОЗУ деген қысқа мерзімге мәлімет сақтауға арналған. компьютерде жасалып жатұан операциялардың бәрң осы озуда сақталады. компьютерді өшіргенде бәрі кетіп қалады.
Материнская плата деген компаның орталық астанасы. Процессор, озу, слоттар, жесткий диск бәрң соған қосып жалғанады.
Видеокарта деген графикалық ақпараттардың қалыпты жұмыс істеуіне арналған. Видео және ойындардың графикасына жауап беретін құрылғы осы.
begin
read(k);
if k div 7=k/7 then n:=7 else
if k+1 div 7=k+1/7 then n:=6 else
if k+2 div 7=k+2/7 then n:=5 else
if k+3 div 7=k+3/7 then n:=4 else
if k+4 div 7=k+4/7 then n:=3 else
if k+5 div 7=k+5/7 then n:=2 else
if k+6 div 7=k+6/7 then n:=1;
writeln(n);
end.
б)var k,n:integer;begin
read(k);
if k-1 div 7=k-1/7 then n:=7 else
if k div 7=k/7 then n:=6 else
if k+1 div 7=k+1/7 then n:=5 else
if k+2 div 7=k+2/7 then n:=4 else
if k+3 div 7=k+3/7 then n:=3 else
if k+4 div 7=k+4/7 then n:=2 else
if k+5 div 7=k+5/7 then n:=1;
writeln(n);
end.
1.) программаға сәйкес операцияларды орындауға арналған компьютердің негізгі құрылғысы, қызметтік бөлігі. Көптеген жартылай өткізгішті элементтерден тұратын және компьютерде барлық есептеулер мен ақпарат өндеу жұмыстарын орындайтын электрондық микросхема. Қазіргі компьютерлерде бір немесе бірнеше процессорлар жұмыс істейді.
2.Процессор деген компьютердегі барлық қызметті атқарып тұрған адамның миы сияқты құрылғы, арифметикалық-логикалық қызметтер атқарады. процессорды CPU американдық компаниялар Intel, AMD жасап шығарады.
ОЗУ деген қысқа мерзімге мәлімет сақтауға арналған. компьютерде жасалып жатұан операциялардың бәрң осы озуда сақталады. компьютерді өшіргенде бәрі кетіп қалады.
Материнская плата деген компаның орталық астанасы. Процессор, озу, слоттар, жесткий диск бәрң соған қосып жалғанады.
Видеокарта деген графикалық ақпараттардың қалыпты жұмыс істеуіне арналған. Видео және ойындардың графикасына жауап беретін құрылғы осы.
Объяснение: