В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dimat123
dimat123
25.02.2022 03:16 •  Информатика

Составить программу, печатающую числа в диапазоне от 45 до 369, которые не делятся на 6, но оканчиваются на цифру 6. нужно составить в pascal'e. нужно

Показать ответ
Ответ:
Pozetiv4ik24
Pozetiv4ik24
10.04.2023 10:56

не так уж и трудно, если

program project2;

var

n,a,b,c,i,k,max,min: longint;

inp,outp: text;

begin

assign(inp,'input.txt');

reset(inp);

assign(outp,'output.txt');

rewrite(outp);

readln(inp,n);

max: =0;

min: =0;

c: =0;

for i: =1 to n do

begin

read(f1,a);

if i=1 then

b: =a;

if a> max then

max: =a;

k: =a-c;

c: =a;

if k< 0 then

begin

k: =abs(k);

min: =min+k;

if k> min then

min: =k;

end;

end;

max: =max-b;

write(outp,max,' ',min);

close(inp);

close(outp);

end.

0,0(0 оценок)
Ответ:
arkadikmxitary
arkadikmxitary
05.06.2021 18:41

рассмотрим выражение x< 5. оно истинно для всех ответов рассмотрим выражение x< 3. оно истинно для 1, 2 и ложно для 3, 4 рассмотрим первую импликацию: две истины истину, значит для ответов 1,2 вторую импликацию (после или) можно не рассматривать, поскольку первая часть истинна.для вариантов 3,4 рассмотрим вторую импликацию.выражения x< 2 и x< 1 для вариантов 3,4 ложь. импликация, где оба аргумента ложь, истинна. получается, что для ответов 3,4 истинна вторая импликация, а значит значение первой несущественно (для оператора или).отсюда следует, что выражение "((x  <   5)→(x  <   3))  или  ((x  <   2)→(x  <   1))" истинно при всех перечисленных значениях х: 1, 2, 3, 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота