В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Viktoria200430
Viktoria200430
01.01.2020 21:29 •  Информатика

Составить программу паскаль. ввести координаты двух точек на плоскости ,на экран вывести номер четверти координатной плоскости. заранее

Показать ответ
Ответ:
vera186
vera186
08.10.2020 23:14

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

procedure LocationPrint(x, y: real);

begin

 if x = 0 then

   if y = 0 then Writeln('Начало координат')

   else Writeln('Ось Y')

 else

 if y = 0 then Writeln('Ось X')

   else

 if x > 0 then

   if y < 0 then Writeln('Четвертая четверть')

   else Writeln('Первая четверть')

     else

 if y < 0 then Writeln('Третья четверть')

 else Writeln('Вторая четверть')

end;


begin

 loop 2 do

 begin

   var (x, y) := ReadReal2('Введите координаты x и y:');

   LocationPrint(x, y)

 end

end.

0,0(0 оценок)
Ответ:
bondarantona
bondarantona
08.10.2020 23:14

Вот так например:

program find_quarter;

var x, y: real;

begin

read(x);

read(y);

if (x > 0) and (y > 0) then writeln('1')

else if (x < 0) and (y > 0) then writeln('2')

else if (x < 0) and (y < 0) then writeln('3')

else writeln('4');

end.


Составить программу паскаль. ввести координаты двух точек на плоскости ,на экран вывести номер четве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота