В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sonua3
sonua3
03.07.2022 14:28 •  Информатика

Составить программу паскаль к : 1)в 200 граммах воды растворили 25 грамм поваренной соли. найдите массовую долю соли в растворе? 2)вычислить площадь и периметр прямоугольного треугольника по заданным длинам двух катетов а и b

Показать ответ
Ответ:
1.
Program tt;
var  A,B,C,D: Real;
begin      
Writeln ('Введите массу воды в граммах.'); Readln(A);      
Writeln ('Введите массу соли в граммах.'); Readln(B); 
D := B+A;
C := B/A;
Writeln ('Массовая доля соли в раствворе - ',C,'.');
End.    
2.
Program tt;
var  A,B,PL,Per: Real;
begin      
Writeln ('Введите длинну первого катета.'); Readln(A);      
Writeln ('Введите длинну второго катета.'); Readln(B); 
PL := (B*A)/2;
PER := sqrt(B*B+A*A)+A+B;
Writeln ('Площадь - ',PL,'.');
Writeln ('Периметр - ',PER,'.');
End.    
0,0(0 оценок)
Ответ:
андрей90321
андрей90321
01.10.2020 15:57
1) Program abc;
var a,b:integer;
     x:real;
begin
writeln('Введите массу воды');
readln(a);
writeln('Введите массу раствора');
Readln(b);
x:=b/a*100;
writeln(x,'%');
end.
2)
Program tt;
var  a,b,c,P:integer;
     S:real;
begin
writeln('Введите первый катет');
readln(a);
writeln('Введите второй катет');
readln(b);
c:=sqr(a)+sqr(b);
P:=a+b+c;
S:=a*b/2;
writeln('Площадь=',S,' ','Периметр=',P);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота