В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
TeamFortres2
TeamFortres2
19.06.2022 08:17 •  Информатика

Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программирования Pascal)

Показать ответ
Ответ:
vitalicc
vitalicc
25.01.2021 13:48

см. объяснения + скрин

Объяснение:

program prog;

var

  num,chetnoe,nechetnoe,ost :integer;

begin

writeln('Vvedite chislo:');

readln(num);

chetnoe:=0;

nechetnoe:=0;

if num=0 then chetnoe:=1 else

begin

 while (num<>0) do begin

  ost:=(num mod 10) mod 2;

  if (ost=0) then chetnoe:=chetnoe+1

  else nechetnoe:=nechetnoe+1;

  num:=num div 10;

 end;

end;

writeln('четныx = ',chetnoe);

writeln('нечетных = ',nechetnoe);

end.


Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программиров
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота