В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу,определяющую сумму положительных элементов одномерного массива b,состоящего из 14 вещественных значений

Показать ответ
Ответ:
YakovlevaJulia2004
YakovlevaJulia2004
09.10.2020 23:16

var

 B: array [1..14] of Real;

 i: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Mассив:');

 for i := Low (B) to High (B) do begin

   B [i] := Random (100) - 50;

   Write (B [i]:5:2, ' ');

 end;

 s := 0;

 for i := Low (B) to High (B) do begin

   if B [i] > 0 then

     s := s + B [i];

 end;

 WriteLn;

 WriteLn ('Сумма положительных элементов массива = ', s:5:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота