В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
evilziro
evilziro
04.06.2021 18:30 •  Информатика

Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат). результат работы программы вывести в виде текстового сообщения. (параметры r, r1, r2, a, b,с вводятся с клавиатуры.) - если имеются

Показать ответ
Ответ:
esalinder22
esalinder22
11.08.2020 17:52

отправь нарушение ошипся я не знаю

0,0(0 оценок)
Ответ:
danek20063
danek20063
11.08.2020 17:52

var

 x, y, r: real;

begin

 read(x, y, R);

 if (x * x + y * y <= R * R) or

   (y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then

   write('попадает')

 else

   write('не попадает');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота