В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
XxNoNamexX
XxNoNamexX
15.07.2022 11:18 •  Информатика

Составить программу.Определите количество отрицательных элементов в целочисленном массиве длины 30 (массив заполняется с клавиатуры).​

Показать ответ
Ответ:
//Я просто опишу метод записи матрицы
const n=100;
var ar:array of array of integer;
 ars:array of array of string;
 i:integer;
 
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
 i,j:integer;
begin;
for i:=1 to n do
 begin;
   for j:=1 to n do
    begin;
     ar[i,j]:=random(9);
     str(ar[i,j],ars[i,j]);
    end;
 end;
end;

procedure burning(ars:array of array of string);
var
 i,j:integer;
 t:text;
 begin;
  assign(t,'text.txt');
  rewrite(t);
  for i:=1 to n do
   begin;
    writeln(t,' ');
     for j:=1 to n do
      write(t,ars[i,j],' ');
   end;
 end;  

begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
 begin;
  setlength(ar[i],n+1);
  setlength(ars[i],n+1);
 end;
complection(ar,ars);
burning(ars);
end.
0,0(0 оценок)
Ответ:
sirkovake
sirkovake
01.12.2021 02:10
Для стека:
const
  MAX_SIZE = 100;
var
  size, n: integer;
  stack: array[1..MAX_SIZE] of integer;

procedure push(a: integer);
begin
  inc(size);
  stack[size] := a;
end;

procedure view;
var
  i: integer;
begin
  for i := 1 to size do
    write(stack[i], ' ');
  writeln;
end;

Для очереди:
const
  MAX_SIZE = 100;
var
  head, tail: integer;
  queue: array[1..MAX_SIZE] of integer;

procedure push(a: integer);
begin
  queue[tail] := a;
  inc(tail);
end;

procedure view;
var
  i: integer;
begin
  for i := head to tail - 1 do
    write(queue[i], ' ');
  writeln;
end;

И стек и очередь реализованы с массива. Нужно следить, чтобы размер структуры не был больше размера массива
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота