В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
JlunaJlove
JlunaJlove
29.11.2022 14:22 •  Информатика

Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)

Показать ответ
Ответ:
Zhenyarishka1
Zhenyarishka1
14.07.2020 13:27
Var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота