В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
артем1ппн
артем1ппн
23.05.2021 08:14 •  Информатика

Составить программу. Найти сумму всех дробей с числителем 2 и знаменателем от 9 до b На языке PYTHON

Показать ответ
Ответ:
Clever23465
Clever23465
01.04.2023 18:02
В программе генерируются только убывающие последовательности (a[i]:=-i+random()+20;). Можно при желании массив вводить с клавиатуры.
const n=15;
var a:array[1..n] of real;
i:integer; b:boolean;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=-i+random()+20;
 write(a[i]:5:2,' ');
 end;
writeln;
b:=true;
for i:=1 to n-1 do
 if a[i+1]>=a[i] then b:=false;
if b
 then 
  begin
  writeln('Последовательность убывающая');
  writeln('p = ',a[n]*a[n div 2+1]:5:2);
  end
 else writeln('Последовательность не убывающая')
end.

Пример:
19.02 18.28 17.91 16.67 15.03 14.68 13.10 12.86 11.91 10.19  9.66  8.35  7.37  6.55  5.20 
Последовательность убывающая
p = 66.86
0,0(0 оценок)
Ответ:
ivankornev00
ivankornev00
17.10.2021 16:26
1. Файл – это:
4) программа или данные на диске, имеющие имя.
 
2. Имя файлу даёт: 
3) программа при его создании
4) пользователь (если нужен один ответ, то выбирать этот. Вообще имя и расширение может выбрать пользователь, а может сгенерировать программа. Если говорить об офисных пакетах, имя выбирает пользователь, расширение по умолчанию выбрано программой)
 
3. Имя файла состоит из двух частей: 
2) имени и расширения (разделенных точкой)
 
4. Расширение  файлу присваивает: 
1) программа при его создании (если нужен один ответ, то выбирать этот.)
3) пользователь
 
5. Файловая система – это: 
4) вложенная структура папок и файлов.
 
6. Папка – это:
1) средство упорядочения тематически связанных файлов; (папка — не именованная область на диске, файлы в папке могут быть физически записаны где угодно)
 
7. В папке могут храниться:                      
2) файлы и папки;
 
8. Какие имена файлов составлены верно:
3) пример.doc; (имя.расширение)
 
9. На тип файла указывает:
1) расширение файла; 
 
10. Укажите тип файла- wav, mp3, midi:
4) звуковой
 
11. Укажите тип файла – txt, doc, pdf
1) текстовый; (называть doc и pdf текстовыми файлами не совсем корректно. Скажем, в них можно вставлять видео — странные "текстовые" файлы. txt — 100% текстовый файл)
 
12. Укажите тип файла – bmp, gif, jpg
3) графический; 
 
13. Какой путь из корневого каталога указан верно:
1) С:\ Обучающие программы \ Поле чудес \ pole.exe; (в системе windows всё начинается с имени диска: буква:, затем список папок и имя файла, всё разделено символом \)
 
14. Задано полное имя файла С:\DOC\PROBA.TXT. Каково имя каталога, в котором находится этот файл?
3) DOC; (каталог DOC находится на диске C и содержит файл PROBA.TXT)
 
15. Укажите тип файла – avi, mpeg, mp4
4) видео.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота