Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
viahseslav
26.12.2021 10:32 •
Информатика
Составить программу: найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]
Показать ответ
Ответ:
Vadimlvo11
03.10.2020 17:18
Var
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
0,0
(0 оценок)
Ответ:
Balabol2010
03.10.2020 17:18
Var
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
jumalieva03
25.05.2023 20:03
Среди приведённых названий устройств отметьте те, что являются устройствами ввода информации: Тачскрин Клавиатура Графопостроитель Микрофон Наушники Видеопроектор Сканер Мышь Встроенный...
lizo4ka004
14.12.2021 08:56
1. Из каких конструктивных узлов состоит ПК? В каком из них находится процессор, оперативная память? 2. Каковы функции центрального процессора? Объясните термин «тактовая частота»...
ilia9999999999
05.08.2021 18:31
Программа на Pythone! Только 23 и буду благодарен! Надо использовать 1. for 2. while! ...
matveeva17vay
26.11.2021 02:26
Построить блок схему:Даны два действительных числа. Найти наибольшее из них...
Ангел23324556
09.02.2022 03:49
10 тестів на тему редагування об єкта...
Derbeshto
26.12.2022 08:11
ПРОЙТИ ТЕСТ ПО ИНФОРМАТИКЕ ОТ КОТОРЫЕ ЕСТЬ https://forms.gle/zHbioHsQKChrJ7AH9...
Йцвсмпнремьливвьс
31.03.2020 23:44
Pascal! необходимо сформировать одномерный массив, элементы которого являются числами фибоначчи fn = fn-1 + fn-2 (f1=1, f2=1). элементы. полученного массива отсортировать по убыванию...
cratospo234
31.03.2020 23:44
За год квартплата работников повышалась дважды. первый раз на 30%, а второй на 40%. год назад семья платила квартплату, которая составляла 4500 тенге в месяц. выведите сумму, которую...
Nastya1138373
29.09.2020 02:53
Расположим по алфавиту десять слов, обозначающих цифры в десятичной системе счисления. возьмём четыре последние из них и из соответствующих цифр составим минимальное возможное...
Lilia3002
12.04.2020 02:40
Составьте блок-схему алгоритма и программу вычисления произведения нечетных чисел, меньших 16. составьте таблицу значений функции у = 4х -5 на отрезке [1; 30] с шагом b=3. составьте...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.