В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sitnikovaalice
sitnikovaalice
25.02.2022 11:36 •  Информатика

Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (N больше или равно 1 и меньше или равно 1000)

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

Показать ответ
Ответ:
tln72
tln72
11.10.2020 20:40

var N,C,D,i: longint;

begin

 assign(input, 'input.txt'); reset(input);

 read(N,C,D);

 C:=C*D;

 for i:=1 to N div C do  

 if N mod (C*i) = 0 then

 write(C*i, ' ');

 writeln();

end.

Объяснение:

но эт не точно

0,0(0 оценок)
Ответ:
manya48
manya48
11.10.2020 20:40

var n,i,s:integer;

begin

read(n);

s:=0;

for i:=n downto 1 do

if n mod i = 0 then  s:=s+i;

write(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота