В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kurtsmolovp00xqx
kurtsmolovp00xqx
02.06.2021 19:24 •  Информатика

Составить программу нахождения суммы трехзначных чисел кратных 5 и 7 и 9

Показать ответ
Ответ:
Adhsvvkdjs
Adhsvvkdjs
25.08.2020 13:48
//Pascal ABC.NET v3.1 сборка 1172

//Продвинутый вариант

begin
 writeln(range(100,999).Where(x -> x mod 7=0).Where(x -> x mod 9=0).Where(x -> x mod 5=0).Sum);
end.

//"Школьный" вариант

Var
 i,s:integer;
begin
 for i:=100 to 999 do
 if (i mod 5=0) and (i mod 7=0) and (i mod 9=0) then s:=s+i;
 writeln(s);
end.

Вывод:
1890
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота