В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
glupiychelovek
glupiychelovek
06.03.2021 07:18 •  Информатика

Составить программу нахождения суммы и произведения первых 10-ти натуральных четных чисел.

Показать ответ
Ответ:
Лина230502
Лина230502
07.04.2023 00:50

# Задание 1

num = input('Введи целое число: ')

print('Количество цифр в числе = {}'.format(len(num)))

# Задание 2

from random import randint

print('Выпало {}'.format(randint(1, 6)))

# Задание 3

a = int(input('Введи 1 число: '))

b = int(input('Введи 2 число: '))

i = min(a, b)

while True:

   if i % a == 0 and i % b == 0:

       break

   i += 1

print(f'НОК = {i}')

# Задание 4

def fibonacci(n):

   a = 0

   b = 1

   if n < 0:

       print("Некорректный ввод!")

   elif n == 0:

       return a

   elif n == 1:

       return b

   else:

       for i in range(2, n):

           c = a + b

           a = b

           b = c

       return b

n = int(input('Введи N-ое число Фибоначчи: '))

print('Число Фибоначчи = {}'.format(fibonacci(n)))

Объяснение:

Python 3.8.2

0,0(0 оценок)
Ответ:
KALINACHKA
KALINACHKA
17.06.2022 22:01

Объяснение:

#include "stdafx.h"

#include <conio.h>

#include <iostream>

#include <cstdlib>

#include <stdio.h>

#include <math.h>

using namespace std;

 

struct Train {  // указатель на узел, динамическую структуру Train

   int number; //ввод поля номер для поезда

   char path[10];// ввод поля пункт назначения поезда

   int hour;// ввод поля время отправления поезда (часы)

   int min; //ввод поля время отправления поезда (минуты стандартных имён

int main() {

   const int N = 5;

   setlocale(LC_ALL, "Russian");// подключение русского  языка  

   Train trains[5];// указание количества поездов в структуре

   for (int i = 0; i < N; i++) { // начало цикла для введения данных о 5 поездах

       cout << "Введите пункт назначения поезда " << i + 1 << endl; // Вывод на экран сообщения о необходимости ввести имя

       cin >> trains[ i ].path ; //ввод имени пользователем

       cout << "Введите номер для поезда " << i + 1 << endl;

       cin >> trains[ i ].number;

   cout << "Введите время отправления для поезда (часы) " << i + 1 << endl;

   cin >> trains[ i ].hour ;

   cout << "Введите время отправления для поезда (минуты) " << i + 1 << endl;

   cin >> trains[ i ].min ;

   }

for(int i = 0; i < N; i++)  

{

    for(int j = i + 1; j < N; j++)  

    {

         if(strcmp(trains[i].path, trains[j].path)>0)

          {

       Train tmp = trains[i];

       trains[i] = trains[j];

       trains[j] = tmp;

          }

    }

}

for (int i = 0; i < N; ++i)  

{

    cout << " Пункт назначения: " << trains[ i ].path << "   номер: " << trains[ i ].number << "   Время отправления: " << trains[ i ].hour << ":" << trains[ i ].min  << endl << endl;

}

int time_h;

int time_min;

int k = 0;

cout << "Введите ваше время (часы затем минуты)" << endl;

cin >> time_h >> time_min;

cout << " Ваше время:" << time_h <<":" << time_min << endl << endl;

for(int i = 0; i < N; i++)

{

    if((time_h < trains[i].hour) || (time_h == trains[i].hour && time_min < trains[i].min))

   {

        cout << " следующие поезда отправятся после вашего времени: " << trains[i].number  <<" с временем "<< trains[i].hour << ":"<< trains[i].min << endl;

        k++;

       }

}

    if(k == 0)

   cout << " Нет подходящих поездов" << endl;

   

_getch();

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота