В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Тролечка
Тролечка
08.04.2021 09:52 •  Информатика

Составить программу нахождения s всех граней куба, объема куба и среднее арифметическое n чисел

Показать ответ
Ответ:
2003Ivann
2003Ivann
12.01.2021 19:36

1) Ақпаратты бағдарламаға түрлендіру тапсырмасын орындайтын және барлық есептеу процестерін басқаруды жүзеге асыратын компьютердің орталық бөлігі.

2) Мақсатына сәйкес процессор регистрлері ерекшеленеді: аккумулятор - арифметикалық және логикалық операциялардың аралық нәтижелерін және енгізу-шығару нұсқауларын сақтау үшін қолданылады; ... контроллерлер - процессордың күйін басқаратын ақпараттарды, сонымен қатар жүйелік кестелердің адрестерін сақтайды.

3) Процессордың негізгі сипаттамалары:

• тактілік жиілік;

• разрядтылық;

• жұмыс кернеуі;

• кэш-жады өлшемі.

0,0(0 оценок)
Ответ:
vis2209
vis2209
15.03.2023 20:57
var a: array[1..2,1..4] of real;
    b,c: string; 
    d,x,y: real;
    i,j: integer;
begin
   b:='ABCD';  c:='xy';
   writeln('трапеция ABCD');
   for i:=1 to 4 do
   begin
     writeln('координаты точки ',b[i],': ');
     for j:=1 to 2 do
     begin
       write('   ',c[j],i,' = ');
       readln(a[j,i]);
     end;  
   end;  
   x:=(a[1,3]-a[1,2]+a[1,4]-a[1,1])/2;
   y:=(a[2,3]-a[2,2]+a[2,4]-a[2,1])/2;
   d:=sqrt(x*x+y*y);
   writeln('длина средней линии:  ',d:5:2);
end.

ввод - вывод

трапеция ABCD
координаты точки A: 
   x1 = 3
   y1 = 2
координаты точки B: 
   x2 = 5
   y2 = 5
координаты точки C: 
   x3 = 9
   y3 = 5
координаты точки D: 
   x4 = 10
   y4 = 2
длина средней линии:   5.50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота