В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
klymukmaks
klymukmaks
28.11.2022 10:41 •  Информатика

Составить программу нахождения площади треугольника по формуле герона. входные данные длины сторон треугольника. выходные данные периметр треугольника, площадь треугольника.

Показать ответ
Ответ:
somofsomof
somofsomof
10.06.2020 18:52

program abc;
uses crt;
var a,b,c,P,S,P2:real;
begin
writeln('Введите первую сторону: ');
readln(a);
writeln('Введите вторую сторону: ');
readln(b);
writeln('Введите третью сторону: ');
readln(c);
if (a+b<c) or (a+c<b) or (b+c<a) then
writeln('Ваш треугольник не существует')
else
P:=a+b+c;
P2:=P/2;
S:=sqrt(P2*(P2-a)*(P2-b)*(P2-c));
writeln('Периметр = ',P);
writeln('Площадь = ',S);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота