В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу нахождения наименьшего общего кратного двух чисел, используя формулу НОК=М*N/НОД

Показать ответ
Ответ:
виктория2003141
виктория2003141
14.03.2021 17:04

1. В.А.Котельников

Объяснение:

Влади́мир Алекса́ндрович Коте́льников (24 августа (6 сентября) 1908 года в Казани — 11 февраля 2005 года в Москве) — советский и российский учёный в области радиофизики, радиотехники, электроники, информатики, радиоастрономии и криптографии. Один из основоположников советской секретной радио- и телефонной связи. Академик АН СССР (23.10.1953), академик РАН (отделение физических наук), вице-президент АН СССР 1970—1988 гг, дважды Герой Социалистического Труда, 4-й кавалер ордена "За заслуги перед Отечеством" I степени.

0,0(0 оценок)
Ответ:
Rekryt123
Rekryt123
23.01.2022 05:04

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота