В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyamagiao
nastyamagiao
24.02.2020 10:22 •  Информатика

Составить программу нахождения корней квадратного уравнения если a=3 b=34 c=4b и выводящую ответ на экран

Показать ответ
Ответ:
Taimy
Taimy
17.07.2020 16:07
Мой код на Java прикреплен, 427 строк где-то (907 в оригинале)
вот код на паскале для твоей задачи
var a,b,c,d:integer;
x1,x2:real;
begin
readln(a,b,c);
d:=(b*b) - (4*a*c); writeln(d);
if d < 0 then writeln('корней нет');
if d = 0 then begin writeln('один корень'); x1:=-b/(2*a); writeln(x1:0:3); end;
if d > 0 then begin writeln('два корня'); x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln(x1:0:3,x2:0:3); end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота