В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
boosoosv
boosoosv
14.08.2022 20:15 •  Информатика

Составить программу нахождения для заданного натурального числа n всех делителей, кратных числу c. формат входных данных входной файл содержит числа n, c (1≤n,c≤1000). формат выходных данных выведите искомые делители. примеры: вход 6 3 выход 3 6 вход 4 15 выход

Показать ответ
Ответ:
Dangerous0
Dangerous0
08.10.2020 21:14

Язык С++

#include <iostream>

using namespace std;

int main(){

int N,C;

cin>>N>>C;

for(int i=1;i<=N/C;i++)

if(N%(i*C)==0)

cout<<i*C<<" ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота