В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alexsupper308
alexsupper308
08.11.2020 16:48 •  Информатика

Составить программу на языке с++, которая решает задачу: Вычислить значение функции y=3x при х<10.3, y=2x, при x>=10.3

Показать ответ
Ответ:
franciskthedirty
franciskthedirty
15.09.2020 06:30

Кодяра:

#include <iostream>

double F(double x) {

   if (x < 10.3)

       return 3*x;

   else

       return 2*x;

}

void print_f(double x) {

   std::cout << "x=" << x << "; F(x)=" << F(x) << std::endl;

}

int main() {

   for (double x = 5; x < 15; x += 4.3)

       print_f(x);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота