В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sashenka585888
Sashenka585888
18.04.2021 17:07 •  Информатика

Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие среднего арифметического, в начало, а остальные - в конец массива. выполнить с использованием второго массива

Показать ответ
Ответ:
blin42p00v7h
blin42p00v7h
09.10.2020 03:31

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;


namespace avg_sort

{

   class Program

   {

       static void Main(string[] args)

       {

           const int N = 10;

           int[] Arr = new int[N];


           Random rand = new Random();

           Console.Write("Исходный массив: ");

           for (int k = 0; k < N; ++k)

           {

               Arr[k] = rand.Next() % 100;

               Console.Write("{0} ", Arr[k]);

           }

           Console.WriteLine();


           double avg = Arr.Average();

           int[] Bufer = new int[N];

           int i = 0, j = N - 1;


           Console.WriteLine("Среднее значение по массиву Avg = {0}", avg);

           for (int k = 0; k < N; ++k)

           {

               if (Arr[k] > avg)

               {

                   Bufer[i] = Arr[k];

                   i++;

               } else

               {

                   Bufer[j] = Arr[k];

                   j--;

               }

           }

           Arr = Bufer;


           Console.Write("Отсортированный массив: ");

           foreach (var el in Arr)

           {

               Console.Write("{0} ", el);

           }

           Console.WriteLine();

       }

   }

}



Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие ср
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота