Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
соня1572
25.06.2020 17:57 •
Информатика
Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х
Показать ответ
Ответ:
miakakashka
26.07.2020 07:20
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000
0,0
(0 оценок)
Популярные вопросы: Информатика
usan2005
18.02.2021 06:35
Укажи минимальный обе памяти (в битах),достаточный для хранения любого расторгнуть изображения размером 45×45 пикселя если известно что в изображении используется палитра из 16 цветов.саму...
lululu4
30.11.2020 03:43
Цикл в фрагменте программыp:=1;repeatp:=p*0.1until p 0.1;будет исполнен:1. 2 раза2. бесконечное число раз3. О раз4. 3 раза5. 1 раз...
liteops04
04.06.2020 22:46
заранее Для хранения растрового изображения размером 201×201 пикселей отвели 16 КБ памяти. Каково максимально возможное число цветов в палитре изображения?...
Kroq123
18.09.2021 20:21
Вычислить определенные интегралы по формуле Ньютона- Лейбница: 1) 2) 3)...
sashashenko
17.12.2021 18:58
Литературный паспорт героя тев є-молочника...
jixeli
12.08.2020 08:06
А 10. Укажите предложение, в котором неправильно расставлены знаки препинания. 1) Гудок парохода будит город и людей. 2) Птенцы выросли, но не улетели. 3) Миша встал и пошел умываться....
AmaliyaLife
17.12.2021 18:58
Запишите в русской транскрипции турецкое слово sükse ‘успех’. ответ не сукс э, не суксэ, не соксэ....
krasotkak31
28.11.2021 20:31
нужно построить отрезок, используя только циркуль и линейку Используя только циркуль и линейку постройте отрезок y= Формула есть в прикреплённом изображении...
маняня4
18.09.2021 20:21
563A. Спиши, встав-Ляя пропущенные буквы ирасставляя знаки препина-Ния. Сформулируй правило Знаки препинания при од-нородных членах предложе-ния . Добавь, где возможно,обобщающие слова.•...
Дисконет
09.11.2021 08:14
Как вы считаете, нужны ли предпринимателю (бизнесу) налоги? 5-6 предложений своё мнение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000