В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

составить программу на языке Пускал по блок схеме. Очень о уже больше часа сижу.

Показать ответ
Ответ:
СлишкомУмная1
СлишкомУмная1
29.06.2022 00:07

Код на C++:

#include <iostream>

#include <ctime>

#include <cmath>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   srand(time(NULL));

   short res = 0;

   for(int i = 0; i < 3; i++)

   {

       res += (rand() % 6) + 1;

   }

   cout << pow(res, 2) << endl;

   

   return 0;

};

Объяснение:

В переменную res мы прибавляем случайное число от 1 до 6 (случайное значение вычисляется при функции rand()). Потом мы число возводим в квадрат и выводим его

0,0(0 оценок)
Ответ:
Фуфик0372
Фуфик0372
13.12.2021 05:10

РЕЖИМЫ ДАТЧИКА СВЕТА: режим "Цвет". Датчик цвета умеет определять семь различных цветов: черный, синий, зеленый, желтый, красный, белый и коричневый цвета. Также если цвет определяется некорректно если предмет назодится далеко от датчика. Датчик определяет отсутствие цвета и приходит в состояние «без цвета».

Режим "Яркость отраженного света". РЕЖИМ ЯРКОСТЬ ОТРАЖЕННОГО СВЕТА: В режиме «яркость отраженного света» датчик цвета определяет яркость света, отраженного света светодиода датчика излучающего красный свет . Датчик использует шкалу от 0 (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он двигался по белой поверхности до тех пор, пока не будет обнаружена черная линия, или чтобы он интерпретировал идентификационную карточку цветовым кодом.

РЕЖИМ ЯРКОСТЬ ВНЕШНЕГО ОСВЕЩЕНИЯ: В режиме«яркость внешнего освещения» датчик цвета определяет силу света, входящего в окошко из окружающей среды, например солнечного света или луча фонарика. Датчик использует шкалу от О (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он подавал сигнал утром, когда восходит солнце, или чтобы он прекрашщал действие, если свет гаснет .

РЕЖИМ ЦВЕТОВ: Частота выборки датчика цвета составляет 1 кГц. Для наибольшей точности при выборе режима «Цвет» или «Яркость отраженного света» датчик следует расположить под прямым углом на расстоянии 10-15 мм к исследуемой поверхности, но не касаясь ее.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота