В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
K12311
K12311
16.12.2022 03:35 •  Информатика

Составить программу на языке паскаль: вычислить значение выражения: f(x)=ctg 3x*log(2x+3)*4 при любых значениях х

Показать ответ
Ответ:
megamerezhnikova
megamerezhnikova
09.09.2020 16:28
Первый вариант: если десятичный логарифм от (2x+3).

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Нельзя вычислить логарифм от нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(2*x+3)*4/(Tan(3*x)*Ln(10)))
End.

Второй вариант: если логарифм по основанию (2x+3) от 4.

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Основание логарифма должно быть больше нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(4)/(Tan(3*x)*Ln(2*x+3)))
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота