Составить программу на языке Паскаль. Вводится с клавиатуры сумма покупки. Если покупка больше или равна 3000р , то делается скидка 15%, если стоимость покупки от 2000р и менее 3000р , то скидка 10%, если покупка от 1500р, но менее 2000р, то скидка 5%. Если сумма меньше, то скидок нет.
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
int a;
cout<<"Введи размерность"<<endl;
cin>>a;
int arr[a+1][a+1];
for (int i=1; i<a+1; ++i)
for(int j=1; j<a+1; ++j)
arr[i][j]=i*j;
for (int i=1; i<a+1; ++i) {arr[i][0]=i;arr[0][i]=i;}
cout<<" ";
for (int i=1; i<a+1; ++i){cout<<arr[i][0]<<" ";}
cout<<endl;
for (int i=1; i<a+1; ++i){
for(int j=0; j<a+1; ++j)
cout<<arr[i][j]<<" ";
cout<<endl;
}
return 0;
}
Т.к. в условии про оформление ничего не сказано, то сделал самое обычное
uses crt;
var
p:integer;
s,s2,pr,ch3:real;
begin
writeln('Стоимость билета 1 класса: ');
read(s);
writeln('Общее количество пассажиров: ');
read(p);
ch3:=(3*(p/4));// 3 четверти пассажиров
pr:=(s/100)*20;// 20% от стоимости
s2:=(ch3*s)+((p/4)*pr);
writeln('Всего заработает за рейс: ',s2);
end.
program cena;
uses crt;
var
k,a,b,m,obc:real;
begin
writeln('Цена за конфеты "Красная шапочка": ');
read(k);
writeln('Цена за конфеты "Алые паруса": ');
read(a);
writeln('Цена за конфеты "Воронежские": ');
read(b);
writeln('Цена за конфеты "Чародейка": ');
read(m);
obc:=0.5*k+0.2*a+0.1*b+0.25*m;
writeln('Всего ',obc,' руб.')
end.