В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Roblox2017
Roblox2017
15.05.2023 03:06 •  Информатика

Составить программу на языке Паскаль, которая удалит третье слово в тексте, который состоит из 5 слов. Текст нужно придумать самостоятельно. На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы. Программная реализация обязательна.

Показать ответ
Ответ:
Madik1111111
Madik1111111
15.09.2021 03:17

Например, так можно сделать (программа удаляет третье слово только если текст состоит из пяти слов):

var

s,t: string;

i,c: integer;

begin

s:='один два три четыре пять';

for i:=1 to length(s) do

begin

if (s[i]<>' ') and ((i=1) or (s[i-1]=' ')) then c:=c+1;

if c<>3 then t:=t+s[i];

end;

if c=5 then s:=t;

write(s);

end.


Составить программу на языке Паскаль, которая удалит третье слово в тексте, который состоит из 5 сло
Составить программу на языке Паскаль, которая удалит третье слово в тексте, который состоит из 5 сло
Составить программу на языке Паскаль, которая удалит третье слово в тексте, который состоит из 5 сло
0,0(0 оценок)
Ответ:
aigamal
aigamal
15.09.2021 03:17

(см. объяснение)

Объяснение:

Решение задачи на PascalABC.NET:

##

ReadString.Split(' ').Where((x,i)->i<>2).Print;

Задание выполнено!

Комментарий:

Можно было решить задачу давно устаревшими в языке приемами.

var a,r: string;

   i,j: integer;

begin

 readln(a);

 i:= 0;

 j:= 0;

 while(j<length(a)) do

 begin

   j:= j+1;

   if(i<>2) then r:= r+a[j];

   if(a[j]=' ') then i:= i+1;

 end;

 writeln(r);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота