В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Emlrd
Emlrd
01.09.2021 16:21 •  Информатика

Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки

Показать ответ
Ответ:
Полюшенцыя
Полюшенцыя
31.08.2020 07:23
A:=a+b;
b:=a-b;
a:=a-b;

var a,b:real;
procedure change(var a, b: real);
begin
a := a + b; writeln(a);  
b := a - b; writeln(b);  
a := a - b; writeln(a);
end;
begin
writeln('a, b:');  
readln(a, b);  
writeln('a=', a);  
writeln('b=', b);  
change(a, b);  
writeln('a=', a);  
writeln('b=', b);  
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота