В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lolkek213
lolkek213
29.09.2020 21:27 •  Информатика

Составить программу на языке pascal: решить квадратное уравнение вида а*х*х+в*х+с=о для произвольных а, в, с.

Показать ответ
Ответ:
89229131414
89229131414
07.10.2020 11:38
Текст плохо форматируется, поэтому скину файлом.
0,0(0 оценок)
Ответ:
polibfbxbdbdbcb
polibfbxbdbdbcb
07.10.2020 11:38
//Pascal
var
  a, b, c, d, x1, x2: real;
begin
  write('Введите a = '); readln(a);
  write('Введите b = '); readln(b);
  write('Введите c = '); readln(c);
  if ((a = 0) and (b = 0) and (c = 0)) then
    writeln('X любое')
  else
  if a <> 0 then
  begin
       d := sqr(b) - 4 * a * c;
       if (d > 0) then
       begin
            x1 := (-b+sqrt(d))/(2*a);
            x2 := (-b-sqrt(d))/(2*a);
            writeln('x1 = ', x1);
            writeln('x2 = ', x2);
       end
       else
       if d = 0 then
       begin
            x1:=-b/(2*a);
            x2:=x1;
            writeln('x1 = ', x1);
            //writeln('x2 = ', x2);
       end
       else
       if d < 0 then
          writeln('Корней нет.');
  end
  else
  if (a = 0) and (b = 0) then
    writeln('Решений нет.')
  else
  if (a = 0) then
  begin
    x1 := (-c)/b;
    writeln('x = ', x1);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота