В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Morij007
Morij007
19.05.2021 03:35 •  Информатика

Составить программу на языке pascal для решения следующей : дана строка. заменить в этой строке все буквы «о» на буквы «а». если букв «о» не встречено в строке, то вывести на экран сообщение «нет буквы «о»

Показать ответ
Ответ:
VolhaRednaya8
VolhaRednaya8
10.08.2022 16:37

Объе́кт — философская категория, обозначающая вещь, явление или процесс, на которые направлена предметно-практическая, управляющая и познавательная деятельность субъекта;

Моде́ль (фр. modèle от лат. modulus «мера, аналог, образец») — система, исследование которой служит средством для получения информации о другой системе; представление некоторого реального процесса, устройства или концепции.

Трёхмерная графика — раздел компьютерной графики, посвящённый методам создания изображений или видео путём моделирования объёмных объектов в трёхмерном пространстве. 3D-моделирование — процесс создания трёхмерной модели объекта. Задача 3D-моделирования — разработать зрительный объёмный образ желаемого объекта.

Программы для цифрового скульптинга (Pixologic ZBrush, Autodesk Mudbox).

Игровые движки (Unreal Engine 4, Unity 5, CryEngine 3).

Узкоспециализированные приложения, «заточенные» под конкретные задачи (анимация жидкостей – RealFlow, создание текстур – Mari и пр.).

Универсальные 3D редакторы (Cinema 4D, 3Ds Max, Maya, Houidini и т.д.).

0,0(0 оценок)
Ответ:
ruslan428
ruslan428
05.08.2022 04:20

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cin >> n;

   vector <int> v(n);

   for(int i = 0; i < n; i++) {

       cin >> v[i];

   }

   int a, b, c, d; //1, 2 макс.; 1, 2 мин.

   a = c = v[0];

   b = d = v[1];

   if(a > b) swap(a, b);

   if(c > d) swap(c, d);

   for(int i = 2; i < n; i++) {

       if(v[i] > a) {

           if(a > b) b = a;

           a = v[i];

       } else if(v[i] > b) {

           b = v[i];

       }

       if(v[i] < c) {

           d = c;

           c = v[i];

       } else if(v[i] < d) {

           d = v[i];

       }

   }

   if(a > b) swap(a, b);

   if(c > d) swap(c, d);

   if(a * b > c * d) cout << a << " " << b;

   else cout << c << " " << d;

}

Объяснение:

Как то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота