В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Hrachuk
Hrachuk
03.02.2023 09:43 •  Информатика

Составить программу на языке ! числа люка определяются так: первое число равно 1, второе равно 3, каждое следующее равно сумме двух предыдущих. составить программу, которая находит сумму первых k чисел люка (k – задается пользователем). определить количество первых чисел люка, таких, что значение ихсуммы не превышает диапазона типа int (long int). вывести в виде таблицы данное значение суммы и три предыдущих значения суммы (с соответствующими количествами чисел люка).

Показать ответ
Ответ:
6aPaLlJek
6aPaLlJek
02.10.2020 00:20
Переделал ваш код с паскаля
#include <iostream>

using namespace std;

int main()
{
long int f[100];
long int k, i, s;
cin>>(k);
f[1] = 1;
f[2] = 3;
if (k > 0) s = 1;
if (k > 1) s = 4;

for (int i = 3;i<=k;i++)
{
f[i] = f[i - 1] + f[i - 2];
s = f[i] + s;
}
cout<<s;
return 0;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота