Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
nastusya0307
08.08.2022 21:03 •
Информатика
Составить программу на языке c++! дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя!
Показать ответ
Ответ:
timofeevele
07.10.2020 06:09
#include <bits/stdc++.h>
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Zen201
23.04.2022 21:06
Вправа 2. Складіть блок-схему фрагмента алгоритму і виконайте його.а) n:= 0;б) р:= 0; a:= 4;for i:=1 to 4 dofor i:=1 to 5 doп:= п + іtіtі:beginа:= 2*a — 1;p:= p+а;end;;Вправа...
Юриякамория
03.12.2021 05:08
Заповни пропуски у команді умов, використовуючи наступні слова- підказки: print, число від’ємне, else, число додатнє, if, elif, це нуль.if (suma 0): ()__ (suma 0):print...
nargizcavid
09.01.2020 12:45
З яких елементів складається текст документа? •Рядок •весь текст •словосполучення •послідовність символів •символ •абзац •слово...
Hictoru
11.06.2021 10:03
Оголошений список — a = [1, 2, 7, 8].Нижче наведені варіанти використання оператора зрізу. Який з них в результаті дасть список [1, 2, 3, 4, 5, 6, 7, 8]? * a[2:] =...
MDA142rus
14.05.2021 21:16
не копируйте с других сайтов кину жалобу :)...
Valya256
27.06.2021 13:59
3. Як можно використати в розгалуженнікоординати положення виконавця на полотніу проектах у Python? Наведіть приклад....
Марк2992
08.11.2022 18:02
Матиндик кужатка силтеме кою ушин кандай мазир жолагы колданылады...
LaimZ
22.04.2021 21:55
Для кодирования букв О, В, Е, К, Л, Р решили использовать двоичное представление чисел 0, 1, 2, 3, 4 и 5 соответственно (с сохранением одного незначащего нуля в случае...
larisa114
09.10.2021 07:14
2. Як можна використати використати в розгалуженні координатиположення виконавця на сцені? Наведіть приклад....
диана2463
04.01.2020 17:47
Выведи на экран большее из двух данных чисел. Запиши программу на языке Паскаль, выведи ответ на экран, если 1.45871 и 2.4578....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}